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Backend Basics
New users to Joomla have a number of basic things that they want to do. Getting used to these few
items will give you the confidence to try other features. You should certainly be able to maintain an
existing Joomla web site if you know these basic features.
• Admin Panel Menu
• Create a new article.
• Edit an existing article.
• Add a photo/image to an article.
• Adding a menu.
• Creating a module.
When you first login to the backend you will land on the Control Panel as seen here. There are two
menu listings. One across the top System… etc. and four down the left hand side.

Admin Panel Menu
The System drop down menu is displayed here. If you ever want to get back to the Control Panel, you
would select it from the System→Control Panel menu tab. This horizontal menu appears on all of the
pages presented on the admin panel. As a beginner, you only need this one menu tab on the System
tab.

The next menu tab, Users, displays user management.

The next menu tab, Menus, manages the menus.

The next menu tab, Content, manages content. Content is comprised of articles and all of your
photograph, clip art, documents etc.

The next tab, Components, is used to manage components within the system. Components are major
parts of the Joomla platform. The new user to Joomla will probably want to use the Contacts
component to add a contact etc. The components menu shows you, by name, the components that are
currently installed within your system. Some listed on this figure may not be included in your system.

The Extension menu tab allows you to select the four types of extensions allowable in Joomla. The
beginning Joomla user will want to access Modules and possibly the Templates.

Create A New Article
There are usually two ways to do anything on the Admin Panel. In this case you can select the New
Article menu tab on the left ( shown by a red arrow ) or select the Content→Articles menu tab.
Clicking New Article takes you straight to the new article editor. Using the Content→ Articles tab
takes you to the Article Manager where you can click the New button.

This page is provided when you click Content→Articles. Select the green New button in the upper
left corner to create a new article. This is the Article Manage page.

Whether you select the “New Article” tab from the Control Panel or the “New” button from the Article
Manager page you will next arrive at the Article Editor shown on the following figure.

Article Editor

NOTE: There is an excellent Help document in the Joomla documention. You can access it via the
Help button in the upper right corner of the Article Editor

Only several of the very basic capabiliities will be provided here.
First: Place a title in the Title field. For demonstration purposes, the title Science will be inserted. Red
arrows are used to show where your input is required. Place some text into the body of the article and
toggle the Featured button to Yes. Click the green Save button in the upper left of the editor screen and

The “Featured” selection forces your new article to the front page of the web site. Note: Every article
you create must have some link within the menu layout or you won’t be able to access it. More on this
later in the section covering Menu Manger. You are now going to view the front page to see your new
article.

Displaying Front Page
When you are on the backend of the Joomla system, most screens can access the front page by clicking
on the web site name in the upper right hand corner of the screen as shown here. This will give you a
new browser screen with the front page displayed. If you already have the front page displayed, you
can refresh the front page using your keyboard and select Ctrl R for “refresh”. Remember to save your
work prior to refreshing the page. The red arrow shows the area to click for the link.

This figure shows the new article displayed on the front page. Note that the size of the display is
somewhat the size of a smart phone in this case. A desktop would show something different. If the
article content is correct, click the Save & Close button on the backend to get out of the editor.

If your article didn’t display, check that you clicked “Featured” within the editor. Featured articles are
forced to the Home page via the menu structure. That’s all there is to creating a new article and
getting it displayed to the home page. Next we will edit an existing article.

Edit An Existing Article
From the Article Manager screen we are going to select the Science article to edit. There are two
ways to make the selection.
1. Check the box in front of the article shown by the green arrow. Then click the Edit button shown by
the upper green arrow. That’s a two step process.
2. Click on the title of the article shown by the red arrow. That’s a one step process.
Either way you article will display in the article editor.
Make your changes and save your article. Go to the home page and refresh to see that the changes
have been made to your specification.
(This is the Article Manager screen)

After saving and closing your article you will arrive back at the Article Manager screen.

Media Manager
The Media Manager is accessed via the Content→ Media menu tab from the Control Panel or the
Media tab on the left side of the Control Panel.

The Media Manager is the place to administer all images, photos, clip art, documents, PDF files,
movies, etc.
This figure displays the Media Manager. Note that the Root: Folder in the Joomla system is, by
convention, “images”. As shown in this figure, there are two folders “headers” and “logos”. Your
system may be different. This figure also displays a PDF file and a drawing.

For this tutorial we are going to upload a clip art into a new folder.

First we click on the “Create New Folder” tab at the top of the Media Manager.
A new line opens up on the form. We type in the name of the new folder as shown here.
NOTE: The Media Manager likes you to use lower case and no spaces in all names.
Add clip-art as the folder name and then click the “Create Folder” button.

You are now returned to the Media Manager with the new folder displaying in the Media Folders
listing on the left side of the screen and the icon of the clip-art folder on the right.

Access the new folder by clicking on either the folder name in the left hand listing or the new folder’s
icon in the middle of the page.

Note that we are now inside the clip-art folder. Also note that the Root: in now images/clip-art. This
is important later if you need to provide a link to an item within the clip-art folder.
At this point, we are going to upload a science clip-art to the folder.

Click on the Upload button in the upper left. A new line opens on the form allowing you to browse on

your PC for the item you want to upload.
Now the Media Manager shows the new clip art that was uploaded. The thumbnail image is
displayed.

Selecting the Detail View button will show you the details of the items in the folder. In this case the
name and size of the file(s). You can toggle between the Thumbnail and Detail views to suit your
purpose.

That’s all there is to uploading a file to the system via the Media Manager.
TIPS: Plan your folder layout prior to developing your web site. Uploading your images prior to
creating articles makes it easier to insert pre loaded photos into your articles. If your site sells shoes
you might want to have folders for men, women and children. Etc.

Inserting Photo Into Article
We are going to select the Science article within the Article Manager and insert the Science space
rocket clip art in the Media Manager.
First: Access the Article Manager via Content->Articles.
Second: Click on the Science article.
Your display should looks something like this.

We are going to insert the science clip-art in front of the word Science in the first sentence. Place your
cursor immediately in front of the S in Science. Then click on the Image icon as shown directly above
the word Science in this figure. On your screen it may be located elsewhere depending on your screen
size and browser settings. The Media Manager popup window will be provided as shown here.

Click down into the folder where your photo is located. In this tutorial “clip-art”. The science image is
clicked on. Then scroll down in the window and select the Image Float selection that you want. None
is the default. Next click the Insert button. At that point we are returned to the Article Manager
editor with the image shown in the article.

Save the article and refresh you home page to see if all is well.
The article appears on the following page.
Justification of the image as to right, left and centered are selected at the point where you select the
image for insertion into the article. That was selected via the Image Float noted above.

That’s all there is to getting a photo inserted into an article.

Menu Manager
The Menu Manager allows you to create menus and add items to existing menus.
To access the Menu Manager select Menus→Manage from the backend menu as shown here.

This next figure is the Menus screen. It shows a listing of the menus currently in your website. The
Main Menu is always provided to have the “Home” position. i.e. the landing page when you access
your website. You will want to see the Items on the menu. i.e. the menu tabs. Click either of the
locations marked by the red arrows. Note that the arrow under “Published” points to a circle with the
number 1 in it. That indicates that there is only one menu item/tab in that menu. As you add menu tabs
to the menu, the number will increase.

The Menu Items will be listed on the menu that you selected. In this case the Main Menu shows the
only menu tab “Home”. The yellow star shown by the red arrow indicates the landing page. You can
assign the landing page for your site by clicking any of the boxes under the Home column. Normally
you will select the “Home” menu tab for Home, but maybe you want some other page to be the landing
page. You would click on it. The yellow star will assign the landing page.

To edit a menu tab click on either the box in front of the line (red arrow) or the blue highlighted name
of the menu tab (green arrow). If you select the box at red arrow, you will next click the Edit button
denoted by the second red arrow.

This figure shows the Menus: Edit Item form. You can change the name of the menu tab which is the
Menu Title. The Home menu tab is usually a blog layout for the featured articles on your site. In this
case you see the Menu Item Type field shows “Featured Articles”. Clicking on the Select button will
provide you with a listing of the type of menu selection represented by the tab.
In this case, we will leave the Home menu tab alone since it is somewhat standard. Click the Close
button and we will move on to the next step: Adding a new menu tab.

Adding A New Menu Tab
This is the items screen for the main menu. We are going to add a new menu tab to the Main menu.
The new menu tab will point to the Science article that we created earlier. Click the green New button.

Enter the name of the menu tab as you want it to appear into the Menu Title field. We will enter
Science. Then click on the Blue Select button for the Menu Item Type.

The Menu Item Type popup screen will show you your choices. In this case we want to have a single
article, the Science article, be the selection. Click on the Articles tab and the listing of the article types
is provided. Select the Single Article blue text at the bottom of the list. The popup will close.
NOTE: More discussion on these Item Types will be presented at the end of of this segment of the
tutorial.

You will see that you’ve selected Single Article for the Menu Item Type and you will next click the
Select button for the Select Article field.

This popup screen will provide a listing of the articles that you can select. Depending on the size of
your site and the number of articles you have, you may have to scroll down the list to select your
article. When you click on the article title you will be immediately taken back to the previous screen.
Science will be selected here.

Next, Save and Close the menu item and go to your home page. Refresh the page and you will see the

new menu tab. Here Science is shown next to Home.

Clicking on the Science menu tab will now take you to the Science article.
Note: The Science article was previously listed as a Featured Article and shows up on the Home page.
You may now edit the Science article and remove the Featured attribute. There may be situations
where you want an article to remain Featured and still have a menu tab. That’s your decision.
That concludes the section on adding a new menu tab to an existing menu. In this case a single article
was added to a menu tab.

Menu Item Types
When you create a menu tab it will point to some type of object within your web site. It may be an
article, a contact , a news feed, a search button, web links etc. etc. As you design your site you may
have any number of types that you want to have accessed via a menu.
This tutorial will keep within the specific area of articles. A beginning web site designer will be most
most familiar with that type of a menu.
Earlier in the tutorial we created a menu tab for a single article. There are seven types of article menu
tabs. Archived, Category Blog, Category List, Crate Article, Featured Articles, List All Categories and
Single Article as shown in this figure.

We have already covered the Single Article. As mentioned earlier, the Home tab points to a blog of
Featured articles. By definition a Blog within Joomla is a page with a collection of articles from one or
more categories. A Category is a specific grouping of items.
Example: You have a web site for a Pet Store. The pet store only sells dogs, cats and fish.
You could have a single article for each of the pet types. i.e. three articles. One for each titled Dogs,
Cats and Fish. There could be a menu tab pointing to each article: Dogs, Cats and Fish. That’s pretty
basic. Each article describes all the animals in a grouping. The Dog article describes all the dogs etc.
As time moves on you would like to talk about each breed of dog, cat and fish. You could create
categories one for each grouping: Dogs, Cats and Fish.
The menu item types would now change to categories. There would be a menu tab for Dogs, Cats and
Fish, but instead of single articles behind each tab, you would now select Category Blog and select the
category for the tab. You would create an article for each dog breed. Doberman, Pit Bull, Beagle etc.
and as you create each article you would assign it to the Dogs category. Clicking on the Dog menu tab
would now take you to a display of all the articles within the Dogs category. As you add new breeds to
your stock you create an article about the breed and place it in the dogs category. When you save the
article it will immediately show up on the page where it is assigned. The menu system takes care of
where the articles appear.
Note: As previously mentioned, if an article is not placed within some category, it will not show up on
the site without some menu tab pointing to it.
On your pet store site you decide that you want to have new categories of dogs. Attack dogs, lap dogs
and show dogs. You would provide for sub menu items under Dogs with categories of Attack, Lap and
Show. The high level Dogs menu tab could point to a list of categories of dogs. Joomla is flexible
enough for you to create various combinations within you menus. As you can see, it’s best to work
most of this out in advance to prevent you from making lots of changes later. Everything boils down to
articles and collections of articles. How do you want to present the various articles on your site?
Thinks of the possibilities: You have a book site. How would you build the menu structure?
You have a window covering site with blinds, shade screens etc. How would you build the menu
structure?

Module Manager
This is a link to the Help screen for the Joomla Module Manager
https://help.joomla.org/proxy/index.php?
option=com_help&keyref=Help36:Extensions_Module_Manager
In a nutshell, modules contain text, photos and/or other info that you want on the site. Modules are
placed in “Positions” based on the template that you are using on your site. There are many templates
available and they all have various positions. Positions can be labled Position 1, 2, 3 etc. or top, right,
left, bottom etc. Some templates have a few positions and other have 20 or more. You must know
where the positions are before you can place your modules.
There is one provision in Joomla whereby you can load a module at a specific location within one of
your articles regardless of the template layout. When you create the module you set it up to load in
“your text” i.e. example paypal.
“Your text” can be anything you want it to be. Examples: weather-report, sales-coupon, my-portrait
etc.
Within your article(s) you use this exact text: {loadposition sales-coupon} or {loadposition paypal}
using the exact text that you used in the module’s load position selected on creation of the module.
Note: this technique can be used multiple times within the same article or within several articles.
Access the Module Manager by clicking Extensions→Modules from the Admin Screen

Module Manager Screen

Note that the Main Menu is a module and it’s located in the nav position in this template.
We will create a new module to hold some text.
Start by clicking the green New button.

You are provided with a listing of the various types of modules within the Joomla system. We are
going to be adding a Site module. The other type of module is Admin which would have been selected
back on the module manager screen. For this demo the Custom module selection will be used.

The next figure, below, shows the editor for the Custom module.

We provide a Title , in this case Beans. You can select to show or hide the title on the page.
Also, we select a position from the dropdown list. If you are going to use your own position type it
into the box provided and make sure you hit the enter key prior to saving. When your module doesn’t
show up where you expect it, you’ll be back here looking for the position.

We have selected “Sidebar2” which is the right hand side in the Favorite template.

Click the Menu Assignment tab to see where the module will display. i.e. menu selections.

The figure above shows that it will display on all pages. You can select the dropdown tab and select
individual pages if you like.

This figure shows the boxes on the dropdown tab. All pages are selected. There may be menu
selections where you don’t want your module to appear. You would unselect those.

This is the new custom module displayed on the Science page in the Sidebar2 position.
Note the title is showing and the text is within the module. This could have been a photo or a link or a
coupon etc.

The content of the module will be distributed within the space allocated for the position it is assigned.
This is all based on the template you are using.
That concludes the Module Manager.

